<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.wmts.org/xmlrpc.php">
<title>Music Mondays: March 12, 2018 | WMTS</title>

<!-- This site is optimized with the Yoast SEO plugin v7.0.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.wmts.org/music-mondays-march-12-2018/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Music Mondays: March 12, 2018 | WMTS" />
<meta property="og:description" content="This week, Ethan keeps it short and sweet with a great selection of alt-rock and electronic music." />
<meta property="og:url" content="http://www.wmts.org/music-mondays-march-12-2018/" />
<meta property="og:site_name" content="WMTS" />
<meta property="article:publisher" content="https://www.facebook.com/wmts88.3/" />
<meta property="article:section" content="Features" />
<meta property="article:published_time" content="2018-03-12T16:24:26-05:00" />
<meta property="article:modified_time" content="2018-03-13T23:27:38-05:00" />
<meta property="og:updated_time" content="2018-03-13T23:27:38-05:00" />
<meta property="og:image" content="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png" />
<meta property="og:image:width" content="1134" />
<meta property="og:image:height" content="489" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="This week, Ethan keeps it short and sweet with a great selection of alt-rock and electronic music." />
<meta name="twitter:title" content="Music Mondays: March 12, 2018 | WMTS" />
<meta name="twitter:site" content="@WMTSradio" />
<meta name="twitter:image" content="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png" />
<meta name="twitter:creator" content="@WMTSradio" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.wmts.org\/","sameAs":["https:\/\/www.facebook.com\/wmts88.3\/","https:\/\/www.instagram.com\/mtsuwmtsradio\/","https:\/\/twitter.com\/WMTSradio"],"@id":"#organization","name":"WMTS FM","logo":"http:\/\/www.wmts.org\/wp-content\/uploads\/2017\/03\/cropped-NewWMTSLogoHEADERLOGO-2.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WMTS &raquo; Feed" href="http://www.wmts.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WMTS &raquo; Comments Feed" href="http://www.wmts.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WMTS &raquo; Music Mondays: March 12, 2018 Comments Feed" href="http://www.wmts.org/music-mondays-march-12-2018/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.0.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_track_user = true;
	var disableStr = 'ga-disable-UA-96754710-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-96754710-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you\'re not being tracked. ");
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
		})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.wmts.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery-style-css'  href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ctct_form_styles-css'  href='http://www.wmts.org/wp-content/plugins/constant-contact-forms/assets/css/style.css?ver=1.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='program-schedule-css'  href='http://www.wmts.org/wp-content/plugins/radio-station/templates/program-schedule.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='dj-widget-css'  href='http://www.wmts.org/wp-content/plugins/radio-station/templates/djonair.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='uaf_client_css-css'  href='http://www.wmts.org/wp-content/uploads/useanyfont/uaf.css?ver=1517253887' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-popup-style-css'  href='http://www.wmts.org/wp-content/plugins/event-calendar-wd/css/ecwd_popup.css?ver=1.1.12_58a35a302e841' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd_font-awesome-css'  href='http://www.wmts.org/wp-content/plugins/event-calendar-wd/css/font-awesome/font-awesome.css?ver=1.1.12_58a35a302e841' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-public-css'  href='http://www.wmts.org/wp-content/plugins/event-calendar-wd/css/style.css?ver=1.1.12_58a35a302e841' type='text/css' media='all' />
<link rel='stylesheet' id='onepress-fonts-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C600%2C700%2C300%2C100%2C800%2C900%7COpen+Sans%3A400%2C300%2C300italic%2C400italic%2C600%2C600italic%2C700%2C700italic&#038;subset=latin%2Clatin-ext&#038;ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='onepress-animate-css'  href='http://www.wmts.org/wp-content/themes/onepress/assets/css/animate.min.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='onepress-fa-css'  href='http://www.wmts.org/wp-content/themes/onepress/assets/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='onepress-bootstrap-css'  href='http://www.wmts.org/wp-content/themes/onepress/assets/css/bootstrap.min.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='onepress-style-css'  href='http://www.wmts.org/wp-content/themes/onepress/style.css?ver=4.9.4' type='text/css' media='all' />
<style id='onepress-style-inline-css' type='text/css'>
#main .video-section section.hero-slideshow-wrapper{background:transparent}.hero-slideshow-wrapper:after{position:absolute;top:0px;left:0px;width:100%;height:100%;background-color:rgba(0,102,204,1);display:block;content:""}.body-desktop .parallax-hero .hero-slideshow-wrapper:after{display:none!important}#parallax-hero>.parallax-bg::before{background-color:rgba(0,102,204,1);opacity:1}.body-desktop .parallax-hero .hero-slideshow-wrapper:after{display:none!important}a,.screen-reader-text:hover,.screen-reader-text:active,.screen-reader-text:focus,.header-social a,.onepress-menu a:hover,.onepress-menu ul li a:hover,.onepress-menu li.onepress-current-item>a,.onepress-menu ul li.current-menu-item>a,.onepress-menu>li a.menu-actived,.onepress-menu.onepress-menu-mobile li.onepress-current-item>a,.site-footer a,.site-footer .footer-social a:hover,.site-footer .btt a:hover,.highlight,#comments .comment .comment-wrapper .comment-meta .comment-time:hover,#comments .comment .comment-wrapper .comment-meta .comment-reply-link:hover,#comments .comment .comment-wrapper .comment-meta .comment-edit-link:hover,.btn-theme-primary-outline,.sidebar .widget a:hover,.section-services .service-item .service-image i,.counter_item .counter__number,.team-member .member-thumb .member-profile a:hover,.icon-background-default{color:#0066cc}input[type="reset"],input[type="submit"],input[type="submit"],.nav-links a:hover,.btn-theme-primary,.btn-theme-primary-outline:hover,.section-testimonials .card-theme-primary,.woocommerce #respond input#submit,.woocommerce a.button,.woocommerce button.button,.woocommerce input.button,.woocommerce button.button.alt{background:#0066cc}.btn-theme-primary-outline,.btn-theme-primary-outline:hover,.pricing__item:hover,.section-testimonials .card-theme-primary,.entry-content blockquote{border-color:#0066cc}#footer-widgets{}.gallery-carousel .g-item{padding:0px 10px}.gallery-carousel{margin-left:-10px;margin-right:-10px}.gallery-grid .g-item,.gallery-masonry .g-item .inner{padding:10px}.gallery-grid,.gallery-masonry{margin:-10px}
</style>
<link rel='stylesheet' id='onepress-gallery-lightgallery-css'  href='http://www.wmts.org/wp-content/themes/onepress/assets/css/lightgallery.css?ver=4.9.4' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var onepress_js_settings = {"onepress_disable_animation":"0","onepress_disable_sticky_header":"0","onepress_vertical_align_menu":"1","hero_animation":"flipInX","hero_speed":"5000","hero_fade":"750","hero_duration":"5000","hero_disable_preload":"","is_home":"","gallery_enable":"1","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/www.wmts.org","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.0.4'></script>
<link rel='https://api.w.org/' href='http://www.wmts.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.wmts.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.wmts.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='http://www.wmts.org/?p=1968' />
<link rel="alternate" type="application/json+oembed" href="http://www.wmts.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wmts.org%2Fmusic-mondays-march-12-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.wmts.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wmts.org%2Fmusic-mondays-march-12-2018%2F&#038;format=xml" />

            <!--/ Facebook Thumb Fixer Open Graph /-->
            <meta property="og:type" content="article" />
            <meta property="og:url" content="http://www.wmts.org/music-mondays-march-12-2018/" />
            <meta property="og:title" content="Music Mondays: March 12, 2018" />
            <meta property="og:description" content="This week, Ethan keeps it short and sweet with a great selection of alt-rock and electronic music." />
            <meta property="og:site_name" content="WMTS" />
            <meta property="og:image" content="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png" />

            <meta itemscope itemtype="article" />
            <meta itemprop="description" content="This week, Ethan keeps it short and sweet with a great selection of alt-rock and electronic music." />
            <meta itemprop="image" content="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png" />
            

<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0c0c0c;}
		</style><link rel="icon" href="http://www.wmts.org/wp-content/uploads/2017/03/cropped-NewWMTSLogoSITELOGO-32x32.png" sizes="32x32" />
<link rel="icon" href="http://www.wmts.org/wp-content/uploads/2017/03/cropped-NewWMTSLogoSITELOGO-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.wmts.org/wp-content/uploads/2017/03/cropped-NewWMTSLogoSITELOGO-180x180.png" />
<meta name="msapplication-TileImage" content="http://www.wmts.org/wp-content/uploads/2017/03/cropped-NewWMTSLogoSITELOGO-270x270.png" />
</head>

<body class="post-template-default single single-post postid-1968 single-format-standard wp-custom-logo ctct-onepress ecwd-theme-onepress group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
    <div id="header-section" class="h-on-top no-transparent">        <header id="masthead" class="site-header header-full-width is-sticky no-scroll no-t h-on-top" role="banner">
            <div class="container">
                <div class="site-branding">
                <div class="site-brand-inner has-logo-img no-desc"><div class="site-logo-div"><a href="http://www.wmts.org/" class="custom-logo-link  no-t-logo" rel="home" itemprop="url"><img width="144" height="144" src="http://www.wmts.org/wp-content/uploads/2017/03/NewWMTSLogoHEADERLOGO-3.png" class="custom-logo" alt="WMTS" itemprop="logo" /></a></div></div>                </div>
                <div class="header-right-wrapper">
                    <a href="#0" id="nav-toggle">Menu<span></span></a>
                    <nav id="site-navigation" class="main-navigation" role="navigation">
                        <ul class="onepress-menu">
                            <li id="menu-item-26" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-26"><a href="http://www.wmts.org/">Home</a></li>
<li id="menu-item-72" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72"><a target="_blank" href="http://www.wmts.org/showschedule/">Show Schedule</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-29"><a target="_blank" href="http://www.wmts.org/media/">Press</a>
<ul class="sub-menu">
	<li id="menu-item-318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-318"><a target="_blank" href="http://www.wmts.org/festivalsandconcerts/">Festivals and Concerts</a></li>
	<li id="menu-item-317" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-317"><a target="_blank" href="http://www.wmts.org/wmts-events/">WMTS Events</a></li>
	<li id="menu-item-316" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-316"><a target="_blank" href="http://www.wmts.org/mtsu-events/">MTSU Events</a></li>
</ul>
</li>
<li id="menu-item-625" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-625"><a target="_blank" href="http://www.wmts.org/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-627" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-627"><a target="_blank" href="http://www.wmts.org/category/features/music-mondays/">Music Mondays</a></li>
	<li id="menu-item-626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-626"><a target="_blank" href="http://www.wmts.org/category/features/festivals/festival-primers/">Festival Primers</a></li>
</ul>
</li>
<li id="menu-item-398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-398"><a target="_blank" href="http://www.wmts.org/category/reviews/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-399"><a target="_blank" href="http://www.wmts.org/category/reviews/new-release/">New Releases</a></li>
	<li id="menu-item-400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-400"><a target="_blank" href="http://www.wmts.org/category/reviews/retrospective/">Retrospective</a></li>
</ul>
</li>
<li id="menu-item-413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-413"><a target="_blank" href="http://www.wmts.org/festivals/">Festivals</a>
<ul class="sub-menu">
	<li id="menu-item-1879" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1879"><a href="http://www.wmts.org/forecastle-festival-2018/">Forecastle Festival 2018</a></li>
	<li id="menu-item-1880" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1880"><a href="http://www.wmts.org/bonnaroo-music-arts-festival-2018/">Bonnaroo Music &#038; Arts Festival 2018</a></li>
	<li id="menu-item-1881" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1881"><a href="http://www.wmts.org/hangoutmusicfestival2018/">Hangout Music Festival 2018</a></li>
	<li id="menu-item-1878" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1878"><a href="http://www.wmts.org/rhythm-n-blooms-2018/">Rhythm N&#8217; Blooms 2018</a></li>
</ul>
</li>
<li id="menu-item-71" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71"><a target="_blank" href="http://www.wmts.org/eventcalendar/">Events</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a target="_blank" href="http://www.wmts.org/contact/">Contact</a></li>
                        </ul>
                    </nav>
                    <!-- #site-navigation -->
                </div>
            </div>
        </header><!-- #masthead -->
        </div>
	<div id="content" class="site-content">

		
		<div id="content-inside" class="container right-sidebar">
			<div id="primary" class="content-area">
				<main id="main" class="site-main" role="main">

				
					<article id="post-1968" class="post-1968 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-music-mondays">
	<header class="entry-header">
		<h1 class="entry-title">Music Mondays: March 12, 2018</h1>        		<div class="entry-meta">
			<span class="posted-on">Posted on <a href="http://www.wmts.org/music-mondays-march-12-2018/" rel="bookmark"><time class="entry-date published" datetime="2018-03-12T16:24:26+00:00">March 12, 2018</time><time class="updated hide" datetime="2018-03-13T23:27:38+00:00">March 13, 2018</time></a></span><span class="byline"> by <span class="author vcard"><a  rel="author" class="url fn n" href="http://www.wmts.org/author/ethan-copeland/">Ethan A. Copeland</a></span></span>		</div><!-- .entry-meta -->
        	</header><!-- .entry-header -->

    
	<div class="entry-content">
		<p><a href="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png"><img class="aligncenter size-full wp-image-852" src="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png" alt="" width="1134" height="489" srcset="http://www.wmts.org/wp-content/uploads/2017/05/download-10.png 1134w, http://www.wmts.org/wp-content/uploads/2017/05/download-10-300x129.png 300w, http://www.wmts.org/wp-content/uploads/2017/05/download-10-768x331.png 768w, http://www.wmts.org/wp-content/uploads/2017/05/download-10-1024x442.png 1024w" sizes="(max-width: 1134px) 100vw, 1134px" /></a></p>
<p style="text-align: center;"><span style="text-decoration: underline; font-size: 14pt; font-family: Georgia, Palatino; color: #000000;"><strong>Ethan A. Copeland</strong></span></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;"><strong>&#8220;Short Court Style&#8221; by Natalie Prass</strong></span></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;">Natalie Prass announced her sophomore album <em>The Future and The Past</em> with a new single, “Short Court Style.” Prass originally wrote a stripped-down version of the tune for a friend’s short film, but decided to flush it out to make a more danceable song that teeters on the edge of Yacht Rock, a slight departure from the more subdued soul sound of her self-titled debut. <em>The Future and The Past</em> is out on June 1 via ATO Records.</span></p>
<p><iframe width="800" height="450" src="https://www.youtube.com/embed/0pv7rN-_IWU?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;"><strong>&#8220;Emerald Rush&#8221; by Jon Hopkins</strong></span></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;">Jon Hopkins announced that he had a new album in the works a few weeks ago, but recently detailed the release. “Emerald Rush” is the lead single off of <em>Singularity</em>, Hopkins&#8217;s follow-up to 2013’s <em>Immunity</em>. Hopkins signature piano ambience is overtaken by a pulsating four to the floor rhythm, but still retains a melodic beauty. <em>Singularity</em> is out May 4 via Domino Recording Company.</span></p>
<p><iframe width="800" height="450" src="https://www.youtube.com/embed/4sk0uDbM5lc?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;"><strong>&#8220;Hold On, Magnolia&#8221; by Songs: Ohia aka Magnolia Electric Co.</strong></span></p>
<p><span style="font-size: 14pt; font-family: Georgia, Palatino; color: #000000;">Five years ago this Friday March 16th, Jason Molina, leading force behind the alt-country outfits Songs: Ohia and Magnolia Electric Co., passed away at the age of 39. Here he is performing “Hold On Magnolia” with Magnolia Electric Co. live in Birmingham, Alabama in 2009.</span></p>
<p><iframe width="800" height="450" src="https://www.youtube.com/embed/6gBaolYCbyE?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
			</div><!-- .entry-content -->
    	<footer class="entry-footer">
		<span class="cat-links">Posted in <a href="http://www.wmts.org/category/features/" rel="category tag">Features</a>, <a href="http://www.wmts.org/category/features/music-mondays/" rel="category tag">Music Mondays</a></span>	</footer><!-- .entry-footer -->
    </article><!-- #post-## -->


					
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/music-mondays-march-12-2018/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.wmts.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1968' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7df7773c71" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="210"/></p>			</form>
			</div><!-- #respond -->
		<script type="text/javascript">
		jQuery( document ).ready( function( $ ) {
			$( '.comment-form, #registerform' ).append( '<input type="hidden" name="js-spam-prevention" value="041b5e316d0231ac9e39d1c76a6e1794"/>' );
		} );
	</script>
	
</div><!-- #comments -->

				
				</main><!-- #main -->
			</div><!-- #primary -->

                            
<div id="secondary" class="widget-area sidebar" role="complementary">
	<aside id="custom_html-3" class="widget_text widget widget_custom_html"><h2 class="widget-title">Stream:</h2><div class="textwidget custom-html-widget"><!-- BEGINS: AUTO-GENERATED MUSES RADIO PLAYER CODE -->
<script type="text/javascript" src="https://hosted.muses.org/mrp.js"></script>
<script type="text/javascript">
MRP.insert({
'url':'http://s1.myradiostream.com:12824/;listen.mp3',
'codec':'mp3',
'volume':100,
'autoplay':false,
'jsevents':true,
'buffering':0,
'title':'WMTS - Noise You Can Trust',
'wmode':'transparent',
'skin':'mcclean',
'width':180,
'height':60
});
</script>
<!-- ENDS: AUTO-GENERATED MUSES RADIO PLAYER CODE --></div></aside><aside id="media_image-2" class="widget widget_media_image"><a href="http://hangoutmusicfest.com/?mkt_campaign=6S08T8G8382Z3GGHH4BFGU71%20"><img width="300" height="300" src="http://www.wmts.org/wp-content/uploads/2017/11/hangout2018-728x728-1-2-300x300.jpg" class="image wp-image-1447  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="http://www.wmts.org/wp-content/uploads/2017/11/hangout2018-728x728-1-2-300x300.jpg 300w, http://www.wmts.org/wp-content/uploads/2017/11/hangout2018-728x728-1-2-150x150.jpg 150w, http://www.wmts.org/wp-content/uploads/2017/11/hangout2018-728x728-1-2.jpg 728w" sizes="(max-width: 300px) 100vw, 300px" /></a></aside><aside id="dj_widget-2" class="widget DJ_Widget">		<div class="widget">
			<h2 class="widget-title">On-Air:</h2>			
			<ul class="on-air-list">
				<li class="on-air-dj"><a href="http://www.wmts.org/show/easy-money-sports/">Easy Money Sports</a><span class="radio-clear"></span></li>			</ul>
		</div>
		</aside><aside id="dj_upcoming_widget-2" class="widget DJ_Upcoming_Widget"> 		
 		<div class="widget">
 		<h2 class="widget-title">Up Next:</h2> 		<ul class="on-air-upcoming-list">
			<li class="on-air-dj"><a href="http://www.wmts.org/show/butterfly-effect/">Butterfly Effect</a><span class="radio-clear"></span></li>			</ul>
		</div>
		</aside><aside id="text-7" class="widget widget_text">			<div class="textwidget"><a class="twitter-timeline" data-width="250" data-height="500" data-theme="light" data-link-color="#0066CC" href="https://twitter.com/WMTSradio">Tweets by WMTSradio</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></div>
		</aside></div><!-- #secondary -->
            
		</div><!--#content-inside -->
	</div><!-- #content -->

    <footer id="colophon" class="site-footer" role="contentinfo">
                        <div class="footer-connect">
            <div class="container">
                <div class="row">
                     <div class="col-md-8 offset-md-2 col-sm-12 offset-md-0">        <div class="footer-social">
            <h5 class="follow-heading">Keep Updated</h5><div class="footer-social-icons"><a target="_blank" href="https://www.facebook.com/wmts88.3" title="Facebook"><i class="fa  fa-facebook"></i></a><a target="_blank" href="https://twitter.com/WMTSradio" title="Twitter"><i class="fa  fa-twitter"></i></a><a target="_blank" href="http://instagram.com/mtsuwmtsradio" title="Instagram"><i class="fa  fa-instagram"></i></a></div>        </div>
        </div>                </div>
            </div>
        </div>
    
        <div class="site-info">
            <div class="container">
                                    <div class="btt">
                        <a class="back-top-top" href="#page" title="Back To Top"><i class="fa fa-angle-double-up wow flash" data-wow-duration="2s"></i></a>
                    </div>
                                        Copyright &copy; 2018 WMTS        <span class="sep"> &ndash; </span>
        <a href="https://www.famethemes.com/themes/onepress">OnePress</a> theme by FameThemes                    </div>
        </div>
        <!-- .site-info -->

    </footer><!-- #colophon -->
    </div><!-- #page -->

<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/plugins/event-calendar-wd/js/gmap/gmap3.js?ver=1.1.12_58a35a302e841'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/plugins/event-calendar-wd/js/ecwd_popup.js?ver=1.1.12_58a35a302e841'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwd = {"ajaxurl":"http:\/\/www.wmts.org\/wp-admin\/admin-ajax.php","ajaxnonce":"7b14343404","loadingText":"Loading...","event_popup_title_text":"Event Details","plugin_url":"http:\/\/www.wmts.org\/wp-content\/plugins\/event-calendar-wd","gmap_key":"AIzaSyBC-wZQCrIneTFTQMPenpNNjjxjpPeoKak","gmap_style":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/plugins/event-calendar-wd/js/scripts.js?ver=1.1.12_58a35a302e841'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/themes/onepress/assets/js/plugins.js?ver=2.0.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/themes/onepress/assets/js/bootstrap.min.js?ver=2.0.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-content/themes/onepress/assets/js/theme.js?ver=2.0.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.wmts.org/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script async="async" type='text/javascript' src='http://www.wmts.org/wp-content/plugins/akismet/_inc/form.js?ver=4.0.3'></script>

</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/


Served from: www.wmts.org @ 2018-03-16 06:24:07 by W3 Total Cache
-->